Error al actualizar WordPress: “Download failed.: SSL certificate problem: unable to get local issuer certificate”

Error al actualizar WordPress: “Download failed.: SSL certificate problem: unable to get local issuer certificate”

Este error se produce al actualizar versiones viejas de Wordpress en servidores que no tienen configurado correctamente SSL. Puede ocurrir en instalaciones locales como con...
Este error se produce al actualizar versiones viejas de Wordpress en servidores que no tienen configurado correctamente SSL. Puede ocurrir en instalaciones locales como con XAMPP en la que no estén instalados los certificados. Si te pasa ocn XAMPP, la solución es descargarse el certificado y habilitarlo en php.ini. La descarga del certificado puedes hacerla desde aquí: https://github.com/bagder/ca-bundle/blob/e9175fec5d0c4d42de24ed6d84a06d504d5e5a09/ca-bundle.crt El archivo ca-bundle.crt lo guardas en la carpeta php de tu instalación de XAMPP y luego modificas php.ini para que las variables curl.cainfo y openssl.cafile apunten a esa carpeta: curl.cainfo="E:/xampp/php/ca-bundle.crt" openssl.cafile="E:/xampp/php/ca-bundle.crt"  
Error en Git y Sublime Text 3 “Executable ‘[‘git’]’ was not found in PATH.”

Error en Git y Sublime Text 3 “Executable ‘[‘git’]’ was not found in PATH.”

Este error se produce cuando la ruta al archivo ejecutable de Git no está en las variables de entorno por lo que Sublime Text 3...
Este error se produce cuando la ruta al archivo ejecutable de Git no está en las variables de entorno por lo que Sublime Text 3 no sabe donde está y tenemos que indicárselo en las preferencias de usuario: Así que debemos ir a Preferences > Package Settings > SublimeGit > Settings - User y escribimos ésto: { "git_executables": { "git": ["C:/Program Files (x86)/Git/bin/git.exe"] } } La ruta que aparece entre corchetes deberá ser la de la carpeta donde tienes instalado Git!

WordPress: Error al actualizar Contact Form 7 a 3.9 wpcf7_add_shortcode

Esto de actualizar los plugins suele poner los huevillos de corbata por cosas como ésta. Acabo de actualizar Contact Form 7 y resulta que no...
Esto de actualizar los plugins suele poner los huevillos de corbata por cosas como ésta. Acabo de actualizar Contact Form 7 y resulta que no reconoce la función wpcft_add_shortcode(). Si no la utilizas no hay problema, pero... yo sí. El caso es que he probado algunas cosillas pero no he encontrado una solución todavía, simplemente volver a restaurar la copia de la versión anterior. Argggg

Error en WordPress: cannot read property ‘length’ of undefined

Estos errores aparecen de vez en cuando al cargarse los scripts en un orden en el que no deberían y seguramente debido a algún plugin...
Estos errores aparecen de vez en cuando al cargarse los scripts en un orden en el que no deberían y seguramente debido a algún plugin que tengamos instalado. En una ocasión en la que me ocurrió ésto, se solucionó añadiendo la siguiente línea de código al archivo wp-config.php de Wordpress justo antes de require_once(ABSPATH . 'wp-settings.php'); define('CONCATENATE_SCRIPTS', false );  

Error Dreamweaver: onload en _onopen.htm

Pues nada, que así de repente, un día aparece este error al abrir Dreamweaver y prácticamente no deja hacer nada sin que salga una ventanita...
Pues nada, que así de repente, un día aparece este error al abrir Dreamweaver y prácticamente no deja hacer nada sin que salga una ventanita con un error distinto cada vez. Así que buscando por Google me encuentro con la descripción del problema: se ha corrompido la caché que crea Dreamweaver. Solución: Borrarla.... El archivo en cuestión se llama WinFileCache... y está en la carpeta: C:/Users/tu_usuario/AppData/Roaming/Adobe/Dreamweaver/idioma/Configuration/ Si usas Windows Vista, en el caso de otros Sistemas Operativos.... a buscarla.. jejeje

Error: WordPress Magic Fields | Class _WP_Editors not foud

Si creamos un nuevo post type con Magic Fields y desactivamos el editor, cuando añadimos un campo del tipo "multiline", se produce este error porque...
Si creamos un nuevo post type con Magic Fields y desactivamos el editor, cuando añadimos un campo del tipo "multiline", se produce este error porque falta la clase _WP_Editors. En mi caso el error se produce en el archivo /wp-content/plugins/woocommerce/assets/js/admin/editor_plugin_lang.php En este archivo he añadido la siguiente línea al principio y el error ya no aparece... magia... <?php if ( ! class_exists( '_WP_Editors' ) ) require( ABSPATH . WPINC . '/class-wp-editor.php' );  

Prestashop: Al actualizar a 1.5.5 desaparecen las imágenes de los productos.

El problema es el cambio de sistema de archivado de imágenes. En versiones anteriores hay una opción que permite "Mover" las imágenes al nuevo sistema...
El problema es el cambio de sistema de archivado de imágenes. En versiones anteriores hay una opción que permite "Mover" las imágenes al nuevo sistema y si no has hecho esto antes de actualizar a la versión 1.5.5, las imágenes no se mostrarán en la web. Si te ha pasado esto, prueba con lo siguiente: (más…)

Magento Top Search no devuelve resultados

Recientemente me ha pasado que el formulario de la parte superior de Magento no devuelve resultados. Después de buscar alguna solución, he encontrado ésta que...
Recientemente me ha pasado que el formulario de la parte superior de Magento no devuelve resultados. Después de buscar alguna solución, he encontrado ésta que me funciona. No sé si será la única, pero al menos funciona, aunque no me gusta demasiado porque hay que cambiar el core de Magento... (más…)

Magento Fatal error: Declaration of Zend_Pdf_FileParserDataSource_File::__construct() must be compatible with Zend_Pdf_FileParserDataSource::__construct()

Por lo visto Zend_Pdf no es compatible con las reglas estrictas de herencia de PHP 5.4, aquí podéis ver la descripción del bug. Mientras Zend...
Por lo visto Zend_Pdf no es compatible con las reglas estrictas de herencia de PHP 5.4, aquí podéis ver la descripción del bug. Mientras Zend no solucione este tema, hay dos posibles soluciones, cambiarse a PHP 5.3 o retocar el código de Zend_Pdf en Magento. En el archivo lib/Zend/Pdf/FileParserDataSource.php comentar el constructor y destructor de la clase. // abstract public function __construct(); /** * Object destructor. Closes the data source. * * May also perform cleanup tasks such as deleting temporary files. */ // abstract public function __destruct();

Error en WordPress: Fatal error: Call to undefined function wp() in wp-blog-header.php

Otro error que puede aparecer en Wordpress, así sin más, de un día para otro y sin avisar. Solo que la causa de éste en...
Otro error que puede aparecer en Wordpress, así sin más, de un día para otro y sin avisar. Solo que la causa de éste en concreto no es problema de Wordpress, sino más bien del sistema de archivos del servidor.... el archivo wp-config.php puede estar corrupto!!!. Cuál fue mi sorpresa al ver que el archivo wp-config.php en el servidor figuraba con su fecha de última modificación el día que instalé wordpress y su tamaño era de unos 4K, pero sin embargo, al abrirlo.... ¡estaba vacío! Mal augurio, seguro que ese no es el único archivo que está vacío.... (más…)