Error al actualizar WordPress: “Download failed.: SSL certificate problem: unable to get local issuer certificate”

Este error se produce al actualizar versiones viejas de WordPress en servidores que no tienen configurado correctamente SSL. Puede ocurrir en instalaciones locales como con XAMPP en la que no estén instalados los certificados.

Si te pasa ocn XAMPP, la solución es descargarse el certificado y habilitarlo en php.ini.

La descarga del certificado puedes hacerla desde aquí: https://github.com/bagder/ca-bundle/blob/e9175fec5d0c4d42de24ed6d84a06d504d5e5a09/ca-bundle.crt

El archivo ca-bundle.crt lo guardas en la carpeta php de tu instalación de XAMPP y luego modificas php.ini para que las variables curl.cainfo y openssl.cafile apunten a esa carpeta:

 

Comments