Error: WordPress Magic Fields | Class _WP_Editors not foud

Si creamos un nuevo post type con Magic Fields y desactivamos el editor, cuando añadimos un campo del tipo «multiline», se produce este error porque falta la clase _WP_Editors.

En mi caso el error se produce en el archivo /wp-content/plugins/woocommerce/assets/js/admin/editor_plugin_lang.php

En este archivo he añadido la siguiente línea al principio y el error ya no aparece… magia…

<?php
if ( ! class_exists( '_WP_Editors' ) ) 
 	 require( ABSPATH . WPINC . '/class-wp-editor.php' );

 

Comments